Benutzer-Werkzeuge

Webseiten-Werkzeuge


docuteam:systemanforderungen

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
Letzte Überarbeitung Beide Seiten der Revision
docuteam:systemanforderungen [2019/01/07 11:24]
127.0.0.1 Externe Bearbeitung
docuteam:systemanforderungen [2019/09/12 08:53]
Andreas Nef
Zeile 7: Zeile 7:
     * D:\ 1 TB lokale Disk für die Workbench (Dateiablage) und Tempdirs. Auf dem Ingest-Server braucht es die 3-4 fache Speichermenge wie die grössten Ablieferungen (SIP), die verarbeitet werden sollen.     * D:\ 1 TB lokale Disk für die Workbench (Dateiablage) und Tempdirs. Auf dem Ingest-Server braucht es die 3-4 fache Speichermenge wie die grössten Ablieferungen (SIP), die verarbeitet werden sollen.
  
-===Fedora Commons (Repository Server)===+====Fedora Commons (Repository Server)====
   * 16 GB RAM   * 16 GB RAM
   * Disks   * Disks
     * C:\ Empfehlung von Betriebssystem     * C:\ Empfehlung von Betriebssystem
     * D:\ 100 GB  für Tempdir von Tomcat     * D:\ 100 GB  für Tempdir von Tomcat
-    * E:\ FedoraData Storage (von Vorteil Share, der einfach erweiterbar ist) beginnend bei 1 TB+    * E:\ Fedora Data Storage (von Vorteil Share, der einfach erweiterbar ist) beginnend bei 1 TB
  
 =====Software und Konfigurationen===== =====Software und Konfigurationen=====
-===Clients===  +====Clients==== 
-  * Java 8 +  * Java 8 (siehe [[docuteam:systemanforderungen#anmerkung_zu_java|Anmerkung]]) 
-  * docuteam packer (wird von docuteam geliefert) benötigt Zugriff auf Workbench-Share+  * docuteam packer (wird von docuteam geliefert)\\ Benötigt üblicherweise Zugriff auf einen Share für die gemeinsame SIP-Bearbeitung und -Ablieferung
  
-===docuteam feeder (Ingest Server)=== +====docuteam feeder (Ingest Server)==== 
-==Software== +===Software=== 
-  * OS Windows 2012/2016 64Bit+  * OS Windows 2012/2016 64Bit oder Linux (vorzugsweise Ubuntu LTS 18.04) 
   * Software und Konfiguration   * Software und Konfiguration
-    * Zertifikat für verschlüsselte Verbindungen für IIS +    * Zertifikat für Webserver (Win: IIS, Ubuntu: nginx) 
-    * IIS (wird hauptsächlich als Proxy verwendet)+    * IIS (wird hauptsächlich als Proxy verwendet) mit zusätzlichen Modulen:
       * ARR (Application Request)       * ARR (Application Request)
       * URL Rewrite       * URL Rewrite
-    * Datenbank MySQL oder MS SQL 2012/2014/2016 (Empfohlen MySQL)+    * Datenbank MySQL oder MS SQL Server 2012/2014/2016 (empfohlen MySQL)
     * Optional: Wenn MS SQL zentral verwendet wird, benötigen wir SQL Management Studio     * Optional: Wenn MS SQL zentral verwendet wird, benötigen wir SQL Management Studio
     * Optional: MS Office (nur wenn Dateimigration mit PDF-Tools durchgeführt wird)     * Optional: MS Office (nur wenn Dateimigration mit PDF-Tools durchgeführt wird)
-    * Java JDK und JRE Version 8 +    * Java 8 (JDK/JRE) (siehe [[docuteam:systemanforderungen#anmerkung_zu_java|Anmerkung]])
     * Notepad++     * Notepad++
     * Firefox als zweiten Browser     * Firefox als zweiten Browser
     * 7-zip     * 7-zip
-    * AdobeReader +    * Adobe Reader 
-    * Weitere Softwarepakete werden durch docuteam geliefert und Installiert+    * Weitere Softwarepakete werden durch docuteam geliefert und installiert:
       * Migrationswerkzeuge       * Migrationswerkzeuge
-      * Ruby Komponenten+      * Ruby
       * docuteam feeder       * docuteam feeder
       * docuteam packer       * docuteam packer
  
-==Accounts== +===Accounts=== 
-  * Admin Account für Installation +  * Admin-Account für Installation 
-  * Ein ServiceAccount evtl. nur locale Accounts für PDF-Tools +  * Ein Service-Account evtl. nur locale Accounts für PDF-Tools 
-  * Ein ServiceAccount für die Windows Services (Zugriff auf Workbench muss sichergestellt sein)+  * Ein Service-Account für die Windows-Services (Zugriff auf Workbench muss sichergestellt sein)
  
-==Share==+===Share===
   * Die Workbench muss via Share den Archivbenutzern zur Verfügung gestellt werden   * Die Workbench muss via Share den Archivbenutzern zur Verfügung gestellt werden
-  * Admin Account für Installation 
  
-===Fedora Commons (Repository Server)=== +====Fedora Commons (Repository Server)==== 
-==Software==+===Software===
   * OS Windows 2012/2016 64Bit oder Linux (vorzugsweise Ubuntu LTS 18.04)   * OS Windows 2012/2016 64Bit oder Linux (vorzugsweise Ubuntu LTS 18.04)
   * Software und Konfiguration   * Software und Konfiguration
     * Zertifikat für verschlüsselte Verbindungen für Apache Tomcat (z.B. *.pfx)     * Zertifikat für verschlüsselte Verbindungen für Apache Tomcat (z.B. *.pfx)
-    * Datenbank MySQL oder MS SQL 2012/2014/2016 (Empfohlen MySQL)+    * Datenbank MySQL oder MS SQL 2012/2014/2016 (empfohlen MySQL)
     * Optional: Wenn MS SQL zentral verwendet wird, benötigen wir SQL Management Studio     * Optional: Wenn MS SQL zentral verwendet wird, benötigen wir SQL Management Studio
-    * Java JDK und JRE Version 8 +    * Java 8 (JDK/JRE) (siehe [[docuteam:systemanforderungen#anmerkung_zu_java|Anmerkung]])
     * Notepad++     * Notepad++
     * Firefox als zweiten Browser     * Firefox als zweiten Browser
     * 7-zip     * 7-zip
-    * Weitere Softwarepakete werden durch docuteam geliefert und Installiert+    * Weitere Softwarepakete werden durch docuteam geliefert und installiert:
       * Apache Tomcat 8       * Apache Tomcat 8
       * Fedora Commons       * Fedora Commons
-      * Fedoragsearch +      * Fedora GSearch 
-      * docuteam repository services (ehemalig docuteamOAIS)+      * docuteam repository services (vormals docuteamOAIS)
  
-==Accounts== +===Accounts=== 
-  * Admin Account für Installation +  * Admin-Account für Installation 
-  * ServiceAccount mit Zugriff auf FedoraData Share+  * Service-Account mit Zugriff auf Fedora Data Share
  
 +
 +----
 +
 +==Anmerkung zu Java==
 +Wir entwickeln mit OpenJDK und verwenden die [[https://adoptopenjdk.net/|AdoptOpenJDK]]-Distribution. Im Frühling 2020 werden wir den Wechsel auf Java 11 (LTS) vollziehen.
  
docuteam/systemanforderungen.txt · Zuletzt geändert: 2021/02/15 12:57 von Andreas Nef