Benutzer-Werkzeuge

Webseiten-Werkzeuge


docuteam:sa-editor

**Dies ist eine alte Version des Dokuments!**

Verwaltung der Ablieferungs-vereinbarungen (SA)

Der Verwaltung der Ablieferungsvereinbarungen ist eine browserbasierte Umgebung, in der Ablieferungsvereinbarungen erstellt, verändert und verwaltet werden. Den Editor haben wir getestet mit Internet Explorer, Firefox und Google Chrome. Die Ablieferungsvereinbarungen (Submission Agreements, SA) werden im Hintergrund als XML-Dateien gespeichert und beinhalten Informationen, die relevant für die Abwicklung des Ablieferungs- und Ingest-Prozesses sind, aber auch für das gesamte Preservation Planning.

Anmeldung

Bei Aufruf der Seite im Browser wird ein Login-Fenster angezeigt. Falls Sie noch kein Login besitzen, klicken Sie auf den Link unter den Eingabefeldern, um einen Zugang zu beantragen. Ein Benutzer mit Administrationsrechten muss Sie anschliessend freischalten (siehe Benutzerverwaltung).

Liste der bestehenden SA anzeigen

Anschliessend wird eine Liste der bereits vorhandenen SA angezeigt. Klicken Sie auf einen Eintrag in der Liste, um zu den Bearbeitungsfunktionen zu gelangen.

SA erstellen/kopieren/löschen

Neue SA erstellen

Über das Menü links wird eine neue SA erstellt:

Der Name der neuen SA muss die folgende Struktur aufweisen:

sa_[Organisationskürzel]-[Laufnummer]

also beispielsweise:

sa_DRS2-001

Die SA ist einem Projekt zuzuweisen (in der Regel ist hier das Archiv hinterlegt). Als Konfigurationswahl ist der Eintrag „submAgr“ (Submission Agreement) auszuwählen.

SA kopieren

SA löschen

:!: Administratoren
Die SA können nur von Administratoren gelöscht werden. Die SA wird ohne Nachfrage gelöscht.

SA umbenennen

  1. gewünschte SA kopieren und entsprechend benennen
  2. alte SA löschen

Wenn Sie Gross und Kleinschreibung ändern möchten, müssten Sie folgende Schritte durchführen.

  1. gewünschte SA in Dummy kopieren
  2. alte SA löschen
  3. Dummy SA kopieren und entsprechend benennen
  4. Dummy SA löschen

SA importieren

:!: Administratoren
Die SA werden als XML-Dateien gespeichert. Für einen Import muss diese XML-Datei in einen Ordner mit gleichem Namen kopiert und dieser Ordner dann gezippt werden.


Das ZIP kann nun importiert werden.

SA editieren

Um eine SA zu editieren klickt man diese in der Liste der SA an und gelangt dann in die Bearbeitungsfunktionen:

Hier stehen die folgenden Funktionen zur Verfügung:

  • SA ändern: Dies ist die zentrale Funktion, über welche die SA zur Bearbeitung in einem separaten Fenster (siehe nächster Abschnitt) geöffnet wird.
  • Web-Ansicht generieren: Mit dieser Funktion wird der Inhalt der SA für die Anzeige im Browser vorbereitet und kann bei Bedarf auch ausgedruckt werden.
  • SA exportieren: Die SA wird als XML-Datei in gezippter Form an einen anzugebenden Ort gespeichert.

Editor

Das Bearbeitungsfenster, in welchem die SA erstellt und bearbeitet werden, wird über die oben angezeigte Schaltfläche „SA ändern“ geöffnet. Hierfür ist auf dem eingesetzten Computer die Java-Laufzeitumgebung (JRE) notwendig. Sie kann unter http://www.java.com/de/download/ gratis heruntergeladen werden.

Wird eine neu erstellte und noch leere SA geöffnet, füllt der Editor die wichtigsten Grundlageninformationen bereits automatisch aus:

Klickt man die Fragezeichen links von den Feldbezeichnungen an, werden Detailinformationen zu den einzelnen Feldern angezeigt. Hinter den jeweiligen Feldern wird jeweils mit einem Symbol angezeigt, ob der eingetragene Wert gültig ist oder nicht.

Nach der Bestätigung wird das Hauptfenster geöffnet, wo die weitere Bearbeitung der SA erfolgt.

Darstellung

Es empfiehlt sich, in der linken Fensterhälfte das Register „Einfügen“ auszuwählen, wo Elemente angezeigt werden, die an der Position des Cursors eingefügt werden können.

In der rechten Fensterhälfte wird der Inhalt der SA angezeigt.

Zusatzinformationen

Weist ein Element ein Symbol mit grünen Listeneinträgen auf, so sind zu diesem Element Zusatzinformationen (Attribute) festzulegen. Klicken Sie hierzu auf grüne Listensymbol, um das entsprechende Eingabefenster zu öffnen.

Hilfe (Fragezeichen)

Über die Fragezeichen werden Detailinformationen zu den einzelnen Elementen der SA angezeigt werden:

Die Beschreibung ist in der Regel auf Englisch und Deutsch vorhanden. Im Register „Kinder-Elemente“ wird ersichtlich, welche Unterelemente mindestens einmal (+), genau einmal (keine spezielle Kennzeichnung, oder nicht zwingend (?) vorkommen müssen.

Elemente einfügen

Neue Elemente können via Reiter „Einfügen“ oder das Menü „Einfügen“ in das SA eingefügt werden. Es werden nur Elemente angezeigt, die an der ausgewählten Position möglich sind.
Bsp: Durch Klick auf Ausgangsdatum, wird das Element in das SA eingefügt und auf der rechten Fensterhälfte dargestellt.

Elementinhalte bearbeiten

Mit dem Mauszeiger in das gewünschte Element klicken und den Inhalt bearbeiten.

Element löschen

Der Mauszeiger positionieren und mit der Taste [Del] oder [Backspace] das Element samt Inhalt löschen.

Speichern

Wenn Sie das SA fertig bearbeitet haben, dann speichern Sie es über Datei –

> Speichern.

Tipp

Gängige Shortcuts können verwendet werden.

Formelle Anforderungen

Ist ein Element rot eingefärbt bedeutet dies, dass es noch nicht allen formellen Anforderungen entspricht. Bevor Sie den Status einer SA auf „final“ setzen, sollten Sie sicherstellen, dass alle Elemente gelb sind und damit die SA alle formellen Vorgaben erfüllt. Sie können (englische) Hinweise über die noch fehlenden Punkte erhalten, indem Sie im Menü auf „Datei“ – „Bewertung“ klicken:

SA Baum

Die SA muss einige Mindestdefinitionen enthalten. Diese sind in der folgenden Struktur beschrieben.

Ablieferungsvereinbarung [Zusatzinformationen: Vereinbarungs-ID, Titel, Status]
  Aktenproduzent
    Kontaktinformationen
      Kontakt-ID
      Organisation
      Departement
      Kurzform => SIP-Creator -> Organisation
  Archiv [Zusatzinformationen: ISIL-Code]
    Kontaktinformationen
      Kontakt-ID
      Organisation
      Departement
      Kurzform
  Überblick
    Unterlagen
      Generelle Beschreibung
      Erstellung
    Bewertungsentscheidung
  Datenlieferung [Zusatzinformationen: dssID]
    Titel
    Zeitplan
    Kategorie
    Unterlagentyp (DC)
    Dateiformat

Zusatzinformation

SIP-Creator → Organisation
Im SIP-Creator sieht ein Benutzer nur die SA die seiner Organisation zugeteilt sind. Damit ein SA einer Organisation zugeteilt wird, muss im Feld Kurzform der Name der Organisation stehen. Die Benutzerverwaltung vom SIP-Creator muss der Administrator vornehmen.
Beispiel: Benutzer = „guenter“, Organisation = „Informatik Docuteam“

Beispiele

Zeitplan > Frequenz

Beispiel für eine Ablieferung mit Frequenz.

Web-Ansicht generieren

Damit die Vereinbarung in gut lesbarer Form im Browser dargestellt werden kann wählen Sie wiederum den Menüpunkt „Bearbeitung einer Ablieferungsvereinbarung“ an. Dort wählen Sie dann „Web-Ansicht generieren“ aus.

Über den Link „Open PDF“ ganz oben ist die Vereinbarung auch als druckbare PDF-Datei zugänglich.

SA exportieren

Um eine SA zu exportieren wählen Sie den Menüpunkt „Bearbeitung einer Ablieferungsvereinbarung“ und dann „Ablieferungsvereinbarung exportieren“. Die SA wird als ZIP gespeichert.

SA publizieren

Die SA wurde nun im Hintergrund als XML-Datei erstellt. Die Werkzeuge SIP-Creator, Docupack und Documill werden automatisch mit den neuen Ablieferungsvereinbarungen ausgestattet, was teilweise aber bis zu 15 Minuten verzögert erfolgen kann.

Projektverwaltung

Alle Benutzer können Projekte erstellen. Der entsprechende Benutzer erhält dann auch explizite Rechte um ein SA dem Projekt hinzuzufügen. Ein Administrator kann weitere Teilnehmer einem Projekt zuordnen (siehe Benutzerverwaltung)

Ein Projekt kann nur gelöscht werden, wenn es keine SA enthält.

Ein Projekt kann exportiert werden. Es werden alle SA als XML-Dateien im jeweiligen Verzeichnis exportiert. Für den Import wiederum müssen allerdings die SA einzeln als ZIP verpackt werden (siehe SA importieren).

:!: Administratoren
Projekte werden durch den Administrator verwaltet. Er kann Projekte umbenennen, SA zwischen Projekten verschieben und Teilnehmer (Benutzer) zu Projekten hinzufügen.

Benutzerverwaltung

:!: Administratoren
Neue Benutzer werden erstellt, indem sich diese auf der Login-Seite registrieren. Anschliessend sind in der Benutzerverwaltung alle Anmeldungen für neue Benutzer aufgelistet. Ein Administrator kann nun registrierte Benutzer für den Zugang autorisiren, Benutzerdaten anpassen, den Benutzer zu Projekten hinzufügen oder diesen löschen.

docuteam/sa-editor.1469160589.txt.gz · Zuletzt geändert: 2019/01/07 11:16 (Externe Bearbeitung)